CentOS 8 / 7

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

CentOS 8 / 7

Dovecot mailing list
Hello List,

I have to install a "new" system, what is the best way for this. I like to
install a CentOS System but I only found dovecot for CentOS 7 is this
compatible for CentOS 8 or have I to setup a CentOS 7 System ?

The onboard dovecot is 2.2.36-5 :-(

Thanks for a answer,
--
mit freundlichen Grüßen / best regards

  Günther J. Niederwimmer


Reply | Threaded
Open this post in threaded view
|

Re: CentOS 8 / 7

Dovecot mailing list


On 07/10/2019 15:11, Günther J. Niederwimmer via dovecot wrote:

> Hello List,
>
> I have to install a "new" system, what is the best way for this. I like to
> install a CentOS System but I only found dovecot for CentOS 7 is this
> compatible for CentOS 8 or have I to setup a CentOS 7 System ?
>
> The onboard dovecot is 2.2.36-5 :-(
>
> Thanks for a answer,
>

Dovecot 2.2.36-5 can be installed from the CentOS 8 AppStream repository
using yum/dnf.

Regards,

--
Jonathan
Reply | Threaded
Open this post in threaded view
|

Re: CentOS 8 / 7

Dovecot mailing list
Am 07.10.19 um 17:23 schrieb Jonathan Casiot via dovecot:

>
>
> On 07/10/2019 15:11, Günther J. Niederwimmer via dovecot wrote:
>> Hello List,
>>
>> I have to install a "new" system, what is the best way for this. I
>> like to
>> install a CentOS System but I only found dovecot for CentOS 7 is this
>> compatible for CentOS 8 or have I to setup a CentOS 7 System ?
>>
>> The onboard dovecot is 2.2.36-5 :-(
>>
>> Thanks for a answer,
>>
>
> Dovecot 2.2.36-5 can be installed from the CentOS 8 AppStream
> repository using yum/dnf.
>
> Regards,
>

That's not what he was asking for as he already figured that there is
only 2.2.36-5 in EL8 available.
EL8 introduced some changes that especially affect build
environments/requirements.

For example tcp_wrappers has been dropped and there is also no
quota-devel package yet.
So, it's basically difficult to build certain packages (like dovecot)
due to missing dependencies that can't be resolved yet, unless one
builds the missing dependencies him/herself.

On the other hand I do wonder what's the problem with 2.2.36? You could
install this first and upgrade Dovecot at a later point when Dovecot
2.3.x is available for EL8?


Michael