IMAP stops responding.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

IMAP stops responding.

Søren Peter Skou
Hiya all,

I've experienced that IMAP/IMAPS stops responding. To restore service there is only one way, restart Dovecot completely. This leads to services being interrupted for some people, so it seems to only affect some of the users on the server. But POP3/POP3s is still running happily. Also, it happens more as we approach Rush Hour. All of this leads me to believe that we're facing a problem with clients somehow. I've searched the net for the problem, and dating back I've found references to Apple units being the culprit. So we've taken an old Apple client, and tried to see how many sessions it actually starts, the result of that test was that regardless what we tried it only opened one extra session.

A bit of information, Debian OS :
dovecot-core                   2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - core files
dovecot-imapd                  2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - IMAP daemon
dovecot-mysql                  2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - MySQL support
dovecot-pop3d                  2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - POP3 daemon
dovecot-sieve                  2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - Sieve filters support

the Config itself is fairly simple, lookup through MySQL to find username/password etc - I don't really see any obvious option. Also, limiting users/sessions per IP isn't really a good idea as we have a great deal of customers behind NAT.

Med venlig hilsen/Best regards

Søren P. Skou
Netværkstekniker

[logo]


Teglholmsgade 1
0900 København C

Tlf: 69 12 12 12
E-mail: [hidden email]<mailto:[hidden email]>
Web: www.danskkabeltv.dk<http://www.danskkabeltv.dk/>


image001.png (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: IMAP stops responding.

Bill Shirley
See NATing comment below.

Bill

On 10/20/2017 5:24 AM, Søren Peter Skou wrote:

> Hiya all,
>
> I've experienced that IMAP/IMAPS stops responding. To restore service there is only one way, restart Dovecot completely. This leads to services being interrupted for some people, so it seems to only affect some of the users on the server. But POP3/POP3s is still running happily. Also, it happens more as we approach Rush Hour. All of this leads me to believe that we're facing a problem with clients somehow. I've searched the net for the problem, and dating back I've found references to Apple units being the culprit. So we've taken an old Apple client, and tried to see how many sessions it actually starts, the result of that test was that regardless what we tried it only opened one extra session.
>
> A bit of information, Debian OS :
> dovecot-core                   2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - core files
> dovecot-imapd                  2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - IMAP daemon
> dovecot-mysql                  2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - MySQL support
> dovecot-pop3d                  2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - POP3 daemon
> dovecot-sieve                  2:2.2.27-1~auto+44            amd64        secure POP3/IMAP server - Sieve filters support
>
> the Config itself is fairly simple, lookup through MySQL to find username/password etc - I don't really see any obvious option. Also, limiting users/sessions per IP isn't really a good idea as we have a great deal of customers behind NAT.
NATing shouldn't matter.  The way I understand mail_max_userip_connections, it is per user and IP.  Therefore
(the default being mail_max_userip_connections=10), bob, sally, and tom will each get 10 connections
from the same IP address.

> Med venlig hilsen/Best regards
>
> Søren P. Skou
> Netværkstekniker
>
> [logo]
>
>
> Teglholmsgade 1
> 0900 København C
>
> Tlf: 69 12 12 12
> E-mail: [hidden email]<mailto:[hidden email]>
> Web: www.danskkabeltv.dk<http://www.danskkabeltv.dk/>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: IMAP stops responding.

Joseph Tam-2
In reply to this post by Søren Peter Skou
S?ren Peter Skou <[hidden email]> writes:

> I've experienced that IMAP/IMAPS stops responding.  To restore service
> there is only one way, restart Dovecot completely.  This leads to
> services being interrupted for some people, so it seems to only affect
> some of the users on the server.  But POP3/POP3s is still running
> happily.  Also, it happens more as we approach Rush Hour.

Help us help you: the problem is most likely pointed out in the log files.
Also, a dump of your configurations (doveconf -n) would help.

Offhand, it seems you've hit an IMAP resource limit, such as
mail_max_userip_connections, or perhaps process/memory limits
(e.g. process_limit, vsz_limit, etc.).

Joseph Tam <[hidden email]>