Installation Problem -

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Installation Problem -

Kaushal Gandhi
Hello,

I have installed dovecot Version 1.0.14 on Centos Linux 4.6.

When I do ./configure --with-pam, I get below mentioned error.

Please help

Best Regards
Kaushal

---------------- Error ----------
Making all in imap-login
make[3]: Entering directory `/tmp/dovecot-1.0.14/src/imap-login'
/bin/sh ../../libtool --tag=CC --mode=link gcc  -std=gnu99 -g -O2 -Wall -W
-Wmissing-prototypes -Wmissing-declarations -Wpointer-arith
-Wchar-subscripts -Wformat=2 -Wbad-function-cast
-I/usr/kerberos/include      -o imap-login  client.o client-authenticate.o
imap-proxy.o ../login-common/liblogin-common.a ../lib-imap/libimap.a
../lib-auth/libauth.a ../lib/liblib.a -L/usr/kerberos/lib -lssl -lcrypto
-lgssapi_krb5 -lkrb5 -lcom_err -lk5crypto -lresolv -ldl -lz
gcc -std=gnu99 -g -O2 -Wall -W -Wmissing-prototypes -Wmissing-declarations
-Wpointer-arith -Wchar-subscripts -Wformat=2 -Wbad-function-cast
-I/usr/kerberos/include -o imap-login client.o client-authenticate.o
imap-proxy.o  ../login-common/liblogin-common.a ../lib-imap/libimap.a
../lib-auth/libauth.a ../lib/liblib.a -L/usr/kerberos/lib -lssl -lcrypto
-lgssapi_krb5 -lkrb5 -lcom_err -lk5crypto -lresolv -ldl -lz
../login-common/liblogin-common.a(ssl-proxy-openssl.o)(.text+0x10e9): In
function `ssl_proxy_init':
/tmp/dovecot-1.0.14/src/login-common/ssl-proxy-openssl.c:735: undefined
reference to `SSL_CTX_set_info_callback'
collect2: ld returned 1 exit status
make[3]: *** [imap-login] Error 1
make[3]: Leaving directory `/tmp/dovecot-1.0.14/src/imap-login'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/dovecot-1.0.14/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/dovecot-1.0.14'
make: *** [all] Error 2
--
Reply | Threaded
Open this post in threaded view
|

Re: Installation Problem -

Asheesh Laroia
On Mon, 16 Jun 2008, Kaushal Gandhi wrote:

> Hello,
>
> I have installed dovecot Version 1.0.14 on Centos Linux 4.6.
>
> When I do ./configure --with-pam, I get below mentioned error.

Download the OpenSSL development packages for your distribution.  My guess
is "openssl-devel" but I don't use CentOS.

-- Asheesh.

--
You have taken yourself too seriously.
Reply | Threaded
Open this post in threaded view
|

Re: Installation Problem -

Scott Silva
In reply to this post by Kaushal Gandhi
on 6-15-2008 11:05 PM Kaushal Gandhi spake the following:

> Hello,
>
> I have installed dovecot Version 1.0.14 on Centos Linux 4.6.
>
> When I do ./configure --with-pam, I get below mentioned error.
>
> Please help
>
> Best Regards
> Kaushal
ww.atrpms.net has current dovecot rpms.

--
MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!


signature.asc (266 bytes) Download Attachment