Mail received but not indexed?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Mail received but not indexed?

Dovecot mailing list


I have recently that some users are complaining about that they are not
getting emails. While I see that they are delivered and in the inbox.
When I do a doveadm force-resync -u xxxx INBOX it resolves the problem.
I think this is something recent. Where/how should I resolve this issue?

Recent changes
1. did some os updates 2019-08-27
2. provider took away the ssd for index storage (maybe config issue
having less iops storage?)

CentOS Linux release 7.6.1810 (Core)
dovecot-2.2.36-3.el7.x86_64
mail_location =
mbox:~/mail:INBOX=/var/spool/mail/%u:CONTROL=~/mail/control:INDEX=/var/d
ovecot2/%u/index:LAYOUT=maildir++


PS during force-resync, I am getting these
"index/.INBOX/dovecot.index.log was locked for 176 seconds" on some
users
Reply | Threaded
Open this post in threaded view
|

Re: Mail received but not indexed?

Dovecot mailing list


> On 27 Sep 2019, at 16.06, Marc Roos via dovecot <[hidden email]> wrote:
> CentOS Linux release 7.6.1810 (Core)
> dovecot-2.2.36-3.el7.x86_64
> mail_location =
> mbox:~/mail:INBOX=/var/spool/mail/%u:CONTROL=~/mail/control:INDEX=/var/d
> ovecot2/%u/index:LAYOUT=maildir++


How do you deliver the emails then? dovecot-lda?

Sami

Reply | Threaded
Open this post in threaded view
|

RE: Mail received but not indexed?

Dovecot mailing list

No, it is still old sendmail to /var/spool/mail/


-----Original Message-----
From: Sami Ketola [mailto:[hidden email]]
Sent: vrijdag 27 september 2019 15:17
To: dovecot
Cc: Marc Roos
Subject: Re: Mail received but not indexed?



> On 27 Sep 2019, at 16.06, Marc Roos via dovecot <[hidden email]>
wrote:
> CentOS Linux release 7.6.1810 (Core)
> dovecot-2.2.36-3.el7.x86_64
> mail_location =
> mbox:~/mail:INBOX=/var/spool/mail/%u:CONTROL=~/mail/control:INDEX=/var
> /d
> ovecot2/%u/index:LAYOUT=maildir++


How do you deliver the emails then? dovecot-lda?

Sami



Reply | Threaded
Open this post in threaded view
|

RE: Mail received but not indexed?

Dovecot mailing list
You recommend I should change this? I have already a new setup where I
am using[0]. But the current setup I have now was ok for many many
years.

[0]
FEATURE(`local_lmtp',`[IPC]',`FILE /var/run/dovecot/lmtp')dnl


-----Original Message-----
Subject: RE: Mail received but not indexed?


No, it is still old sendmail to /var/spool/mail/


-----Original Message-----
From: Sami Ketola [mailto:[hidden email]]
Sent: vrijdag 27 september 2019 15:17
To: dovecot
Cc: Marc Roos
Subject: Re: Mail received but not indexed?



> On 27 Sep 2019, at 16.06, Marc Roos via dovecot <[hidden email]>
wrote:
> CentOS Linux release 7.6.1810 (Core)
> dovecot-2.2.36-3.el7.x86_64
> mail_location =
> mbox:~/mail:INBOX=/var/spool/mail/%u:CONTROL=~/mail/control:INDEX=/var
> /d
> ovecot2/%u/index:LAYOUT=maildir++


How do you deliver the emails then? dovecot-lda?

Sami





Reply | Threaded
Open this post in threaded view
|

Re: Mail received but not indexed?

Dovecot mailing list


> On 27 Sep 2019, at 16.38, Marc Roos via dovecot <[hidden email]> wrote:
>
> You recommend I should change this? I have already a new setup where I
> am using[0]. But the current setup I have now was ok for many many
> years.
>
> [0]
> FEATURE(`local_lmtp',`[IPC]',`FILE /var/run/dovecot/lmtp')dnl

Using dovecot-lda is always better from dovecot point of view, but I think still your current config should work even if it is not optimal.

for some reason dovecot now does not detect changes on the mbox file and for that reason does not add new mails to index. But I can't say for sure for what reason.

Sami