Problem compiling antispam plugin with Dovecot 1.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem compiling antispam plugin with Dovecot 1.1

Juan Asensio Sánchez
Hi

I am trying to compile antispam plugin with Dovecot 1.1, but i get an
error when running make install:

pdc-server:~/tmp/dovecot-antispam# make
cc -c  -DHAVE_CONFIG_H -Wall -I/root/tmp/dovecot-1.1.rc5/
-I/root/tmp/dovecot-1.1.rc5/src/ -I/root/tmp/dovecot-1.1.rc5/src/lib/
-I/root/tmp/dovecot-1.1.rc5/src/lib-storage/
-I/root/tmp/dovecot-1.1.rc5/src/lib-mail/
-I/root/tmp/dovecot-1.1.rc5/src/lib-imap/
-I/root/tmp/dovecot-1.1.rc5/src/lib-dict/
-I/root/tmp/dovecot-1.1.rc5/src/lib-index/
-I/root/tmp/dovecot-1.1.rc5/src/imap/ -DCONFIG_DEBUG -DDEBUG_SYSLOG
-DCONFIG_DEBUG_VERBOSE -DCONFIG_DOVECOT_11
"-Dmempool_unref(x)=pool_unref(x)" -fPIC -shared -Wall -Wextra
-DPLUGINNAME=antispam -o debug.o.o debug.c
cc  -DHAVE_CONFIG_H -Wall -I/root/tmp/dovecot-1.1.rc5/
-I/root/tmp/dovecot-1.1.rc5/src/ -I/root/tmp/dovecot-1.1.rc5/src/lib/
-I/root/tmp/dovecot-1.1.rc5/src/lib-storage/
-I/root/tmp/dovecot-1.1.rc5/src/lib-mail/
-I/root/tmp/dovecot-1.1.rc5/src/lib-imap/
-I/root/tmp/dovecot-1.1.rc5/src/lib-dict/
-I/root/tmp/dovecot-1.1.rc5/src/lib-index/
-I/root/tmp/dovecot-1.1.rc5/src/imap/ -DCONFIG_DEBUG -DDEBUG_SYSLOG
-DCONFIG_DEBUG_VERBOSE -DCONFIG_DOVECOT_11
"-Dmempool_unref(x)=pool_unref(x)" -fPIC -shared -Wall -Wextra
-DPLUGINNAME=antispam    antispam-storage-1.1.c   -o
antispam-storage-1.1
cc      -o .o
cc: no input files
make: *** [.o] Error 1

When running make clean to try to compile again, a file called
"antispam-storage-1.1.c" (without any extension) is not deleted, and
this file was not before running make install. If I run again make
install with that file present (after running make clean), i get this
output:

cc -c  -DHAVE_CONFIG_H -Wall -I/root/tmp/dovecot-1.1.rc5/
-I/root/tmp/dovecot-1.1.rc5/src/ -I/root/tmp/dovecot-1.1.rc5/src/lib/
-I/root/tmp/dovecot-1.1.rc5/src/lib-storage/
-I/root/tmp/dovecot-1.1.rc5/src/lib-mail/
-I/root/tmp/dovecot-1.1.rc5/src/lib-imap/
-I/root/tmp/dovecot-1.1.rc5/src/lib-dict/
-I/root/tmp/dovecot-1.1.rc5/src/lib-index/
-I/root/tmp/dovecot-1.1.rc5/src/imap/ -DCONFIG_DEBUG -DDEBUG_SYSLOG
-DCONFIG_DEBUG_VERBOSE -DCONFIG_DOVECOT_11
"-Dmempool_unref(x)=pool_unref(x)" -fPIC -shared -Wall -Wextra
-DPLUGINNAME=antispam -o debug.o debug.c
cc      -o .o
cc: no input files
make: *** [.o] Error 1

If I run make clean and manually deleted that file before running make
install, i get again the first output. Why am i getting this error?

Regards.