Problems with apple'mail client

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with apple'mail client

inle
hi all
I use dovecot for smtp authentication  this works ok for thunderbird
and for outlook express but not for apple'mail client.

my config is as follow

postfx main.cf

.
.
#authentication
smtpd_sasl_auth_enable          = yes
#smtpd_sasl_local_domain        = $myhostname
smtpd_sasl_exceptions_networks  = $mynetworks
smtpd_sasl_security_options     = noanonymous
broken_sasl_auth_clients        = yes
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
# TLS parameters
.
.
Dovecot dovecot.conf

ssl_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
ssl_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
mail_location = maildir:/var/vmail/%d/%u/Maildir
mail_extra_groups = mail
first_valid_uid = 5000
last_valid_uid = 5000
maildir_copy_with_hardlinks = yes
disable_plaintext_auth = no
mail_debug = no
dotlock_use_excl=yes
protocols = imap pop3
protocol imap {
  mail_plugins = quota imap_quota
  imap_client_workarounds = outlook-idle delay-newmail
}
protocol pop3 {
  mail_plugins = quota
  pop3_client_workarounds = outlook-no-nuls oe-ns-eoh
  pop3_uidl_format = %08Xu%08Xv
}
protocol lda {
  postmaster_address = [hidden email]
  mail_plugins = quota
  log_path = /var/log/dovecot-deliver.log
  info_log_path = /var/log/dovecot-deliver.log
}
auth default {
mechanisms = plain login
  passdb sql {
    args = /usr/dovecot/etc/sql.conf
  }
# userdb prefetch {
#  }
  userdb sql {
    args = /usr/dovecot/etc/sql.conf
  }
    user = nobody
  socket listen {
    master {
      path = /usr/dovecot/var/run/dovecot/auth-master
      mode = 0660
      user = vmail
      group = mail
    }
    client {
      path = /var/spool/postfix/private/auth
      mode = 0660
      user = postfix
      group = mail
    }
  }
}
dict {
}
plugin {
}

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: Problems with apple'mail client

Charles Marcus
On 5/22/2008, Osvaldo Alvarez Pozo ([hidden email]) wrote:
> my config is as follow

logs?

--

Best regards,

Charles
Reply | Threaded
Open this post in threaded view
|

Re: Problems with apple'mail client

inle
On Thu, May 22, 2008 at 7:09 PM, Charles Marcus
<[hidden email]> wrote:

> On 5/22/2008, Osvaldo Alvarez Pozo ([hidden email]) wrote:
>>
>> my config is as follow
>
> logs?
>
> --
>
> Best regards,
>
> Charles
>

there is no logs , the macs sends nothing
Reply | Threaded
Open this post in threaded view
|

Re: Problems with apple'mail client

Timo Sirainen
On Fri, 2008-05-23 at 10:01 +0200, Osvaldo Alvarez Pozo wrote:

> On Thu, May 22, 2008 at 7:09 PM, Charles Marcus
> <[hidden email]> wrote:
> > On 5/22/2008, Osvaldo Alvarez Pozo ([hidden email]) wrote:
> >>
> >> my config is as follow
> >
> > logs?
> >
> > --
> >
> > Best regards,
> >
> > Charles
> >
>
> there is no logs , the macs sends nothing
So there are no authentication attempts? Does it even connect to the
Postfix (those should get logged as well)? If not, it's clearly an Apple
mail configuration problem (or a network/firewall problem). I have it
working fine.


signature.asc (196 bytes) Download Attachment