Problems with new installation

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with new installation

Dovecot mailing list
I had Dovecot running very well on Ubuntu 14.04. Then I decided that
since That version of Ubuntu was now out of support, I would build a new
server on 18.04, which has been done.


I thought I could take the old dovecot.conf and everything in conf.d
that had been customized and drop it in place, and everything would just
work. That has proven not to be correct. The files that had been edited
were the main /etc/dovecot/dovecot.conf, and in conf.d, 10-master.conf,
10-ssl.conf, and 10-mail.conf. I have restored the original
package-supplied versions of these files and restarted Dovecot, but
still no one can connect. Here's my configuration, with the version
number at the top:


# 2.2.33.2 (d6601f4ec): /etc/dovecot/dovecot.conf
# Pigeonhole version 0.4.21 (92477967)
# OS: Linux 4.15.0-64-generic x86_64 Ubuntu 18.04.3 LTS
auth_debug = yes
auth_debug_passwords = yes
mail_debug = yes
mail_location = mbox:~/mail:INBOX=/var/mail/%u
mail_privileged_group = mail
namespace inbox {
   inbox = yes
   location =
   mailbox Drafts {
     special_use = \Drafts
   }
   mailbox Junk {
     special_use = \Junk
   }
   mailbox Sent {
     special_use = \Sent
   }
   mailbox "Sent Messages" {
     special_use = \Sent
   }
   mailbox Trash {
     special_use = \Trash
   }
   prefix =
}
passdb {
   driver = pam
}
protocols = " imap lmtp"
userdb {
   driver = passwd
}
verbose_ssl = yes


The edits that were made to the aforementioned files were not actually
done by me, so I can't explain why certain choices were made, except for
obvious ones such as SSL key paths. But I figured the system should work
at least on a vanilla configuration.


Postfix is also involved in this, so the problems may not at all be with
Dovecot, but with Postfix. I think I just need to draw the line between
them and be able to know definitely that at least one half of the system
is functioning correctly so I know I can mark that part as working, and
proceed with debugging the other. My bet at this point is that it's not
a Dovecot problem, but I'm not clear on how to determine this, with or
without my changed files.


Thanks in advance.

Reply | Threaded
Open this post in threaded view
|

Re: Problems with new installation

Dovecot mailing list

On 22.10.2019 8.46, Steve Matzura via dovecot wrote:

> I had Dovecot running very well on Ubuntu 14.04. Then I decided that
> since That version of Ubuntu was now out of support, I would build a
> new server on 18.04, which has been done.
>
>
> I thought I could take the old dovecot.conf and everything in conf.d
> that had been customized and drop it in place, and everything would
> just work. That has proven not to be correct. The files that had been
> edited were the main /etc/dovecot/dovecot.conf, and in conf.d,
> 10-master.conf, 10-ssl.conf, and 10-mail.conf. I have restored the
> original package-supplied versions of these files and restarted
> Dovecot, but still no one can connect. Here's my configuration, with
> the version number at the top:
>
>
> # 2.2.33.2 (d6601f4ec): /etc/dovecot/dovecot.conf
> # Pigeonhole version 0.4.21 (92477967)
> # OS: Linux 4.15.0-64-generic x86_64 Ubuntu 18.04.3 LTS
> auth_debug = yes
> auth_debug_passwords = yes
> mail_debug = yes
> mail_location = mbox:~/mail:INBOX=/var/mail/%u
> mail_privileged_group = mail
> namespace inbox {
>   inbox = yes
>   location =
>   mailbox Drafts {
>     special_use = \Drafts
>   }
>   mailbox Junk {
>     special_use = \Junk
>   }
>   mailbox Sent {
>     special_use = \Sent
>   }
>   mailbox "Sent Messages" {
>     special_use = \Sent
>   }
>   mailbox Trash {
>     special_use = \Trash
>   }
>   prefix =
> }
> passdb {
>   driver = pam
> }
> protocols = " imap lmtp"
> userdb {
>   driver = passwd
> }
> verbose_ssl = yes
>
>
>
You are missing ssl_cert and ssl_key setting at least.. Also, you should
probably look at your logs.

Aki