Recent Dovecot on old operating system

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Recent Dovecot on old operating system

Dovecot mailing list
Hi,

sorry for the dumb question and please ignore this post if you think it's far beyond; i know it's not the way to go, but for reasons ...

Has anyone running a self compiled recent dovecot (2.2.36.4) on Debian-7 and does it work?
 Or thinks it should work.

Surprisingly it actually compiles flawlessly on Debian-7, but i wonder wether it will become a complete mess replacingthe existing dovecot (2.1.7) with the new one, serving a few dozens users and any kind of mail clients.

Libraries of the compiled Dovecot:
$ ldd ./src/master/.libs/dovecot        linux-vdso.so.1 =>  (0x00007ffeacfb1000)
        libdovecot.so.0 => /usr/local/00-DBAI/dovecot/lib/dovecot/libdovecot.so.0 (0x00007f557b2a9000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f557af1c000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f557ad18000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f557ab10000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f557b5dc000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f557a8f4000)

libc6 versions:    Debian-7: 2.13-38    Debian-9: 2.24-11

thanks so far, gerald








Reply | Threaded
Open this post in threaded view
|

Re: Recent Dovecot on old operating system

Dovecot mailing list
Hi
For test in my smal testing lab i downlod latest dovecot-2.2.36.4 and
debian 7.x

./configure --prefix=/usr/local/dovecot-2.2.36.4 --sysconfdir=/etc
--with-mysql --with-ssl=openssl --with-solr --with-storages=maildir,imapc

and make

working ok

debian 7:
dovecot-director

debian 8:
dovecot node

and tested like

debian 8:
dovecot-director

debian 7:
dovecot node

All works fine

On 19.09.2019 12:28, Gerald via dovecot wrote:

> Hi,
>
> sorry for the dumb question and please ignore this post if you think it's far beyond; i know it's not the way to go, but for reasons ...
>
> Has anyone running a self compiled recent dovecot (2.2.36.4) on Debian-7 and does it work?
>  Or thinks it should work.
>
> Surprisingly it actually compiles flawlessly on Debian-7, but i wonder wether it will become a complete mess replacingthe existing dovecot (2.1.7) with the new one, serving a few dozens users and any kind of mail clients.
>
> Libraries of the compiled Dovecot:
> $ ldd ./src/master/.libs/dovecot        linux-vdso.so.1 =>  (0x00007ffeacfb1000)
>         libdovecot.so.0 => /usr/local/00-DBAI/dovecot/lib/dovecot/libdovecot.so.0 (0x00007f557b2a9000)
>         libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f557af1c000)
>         libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f557ad18000)
>         librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f557ab10000)
>         /lib64/ld-linux-x86-64.so.2 (0x00007f557b5dc000)
>         libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f557a8f4000)
>
> libc6 versions:    Debian-7: 2.13-38    Debian-9: 2.24-11
>
> thanks so far, gerald
>
>
>
>
>