Rootless wiki page is not up to date?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Rootless wiki page is not up to date?

Dovecot mailing list

If I run a docker image with the mesos containerizer and altering the
dovecot config mentioned here[1]

I think the root detection is incorrect because it looks like dovecot is
still thinking it is root. I still get errors like:


>> log(829825): Fatal: We couldn't drop root group privileges
(wanted=10053(dovecot), gid=0(root), egid=0(root))

Why does it want to drop to root, if we are not even running as root?

>> Error: service(ipc): chown(/var/dovecot/login/ipc-proxy, 91,
4294967295) failed: Operation not permitted

Why does it want to chown, when it is not root?


pop3-login: Fatal: setgid(101(dovenull)) failed with
euid=10053(dovecot), gid=10053(dovecot), egid=10053(dovecot): Operation
not permitted (This binary should probably be called with process group
set to 101(dovenull) instead of 10053(dovecot))



[1]
https://wiki.dovecot.org/HowTo/Rootless?action=edit&editor=text